Whatsapp degraded
Updated
Jun 12, 2026 at 2:34pm UTC
An update from Meta, see https://metastatus.com/whatsapp-business-api
"" We are currently experiencing high disruptions impacting WhatsApp Cloud API. Our engineering teams are investigating the issue. We will provide another update within 1 hour or sooner if additional information is available. ""
Affected services
Created
Jun 12, 2026 at 2:01pm UTC
We're currently seeing disruption to WhatsApp messaging in Guestway. This is caused by an ongoing issue on Meta's side (the provider behind WhatsApp), which is affecting WhatsApp connectivity for users worldwide — not just Guestway.
What this means: WhatsApp messages may be delayed or fail to send/sync until Meta restores service. All other channels (email and in-app messaging) are unaffected and working normally.
What we're doing: We're monitoring Meta's status closely. Your WhatsApp integration will reconnect automatically once Meta resolves the issue on their end — no action is needed from you.
We'll update this incident as soon as we have more information.
Affected services